Groups
    EXPIRED

    Vauxhall Vectra Warning Light showing anyone have any ideas of whats wrong?

    My car was running great then had an MOT in Nov passed fine then after about 6 weeks light randomly flashed on and off now won't go off and judders at the low end of second gear.

    Anyone have any idea's? it's a Xreg but was running great up until now.

    Thanks

    30 Comments

    Original Poster

    http://i1286.photobucket.com/albums/a607/tjack01/imagesCAFCCUUT_zps523ed9d0.jpg

    Light showing on dash.

    Usually comes on if the car picks up multiple faults with the engine. could be missfires, bad sensor or anything. car dealer can connect to the car and read the code. it will tell them what is wrong. best not to drive.

    as above go to a garage asap - you shouldn't drive it

    it called engine management light it tells you there something wrong with the car

    Need to plug it into a fault reader and get the exact codes etc. Don't pay a garage £30 to do it, order a code reader and the software and do it yourself.

    Search ebay/amazon for "op com"

    i took my car in for one of these plug it up to the computer malarchys and it cost me £45 !!!!!!! As I had a light coming on mine was to do with emissions and had to have something changed cost me an additional £200 !!!!

    This might help you get a code.
    Press break peddle and accelerator peddle hard down then switch the ignition to second position .
    The engine warning light should start to flash a number of times with a small pause between each sequence remember 0 will flash 10 times. This work getting the code for my astra.
    Edited by: "Broxy" 5th Feb 2013

    pinkladyof66

    i took my car in for one of these plug it up to the computer malarchys … i took my car in for one of these plug it up to the computer malarchys and it cost me £45 !!!!!!! As I had a light coming on mine was to do with emissions and had to have something changed cost me an additional £200 !!!!


    LoL that's so weird! I just litterally got a similar problem. bought a fault code reader from ebay for £15, delivered next day, tested and turned out to be the downstream oxygen sensor that's faulty. anyway ford quoted me £220 (£180 for part + £40 for replacement).
    the part on ebay was £43 and i'm doing the replacement myself.

    basically: dyi is worth it most the time.

    Post the code here if it works should be a 4 digit code.

    andreapedrazzini

    LoL that's so weird! I just litterally got a similar problem. bought a … LoL that's so weird! I just litterally got a similar problem. bought a fault code reader from ebay for £15, delivered next day, tested and turned out to be the downstream oxygen sensor that's faulty. anyway ford quoted me £220 (£180 for part + £40 for replacement).the part on ebay was £43 and i'm doing the replacement myself.basically: dyi is worth it most the time.



    Have you got the link to the code reader? Is this code reader for any car? I have a peugeot 307

    Banned

    Does your clutch feel normal?

    demolisher

    Have you got the link to the code reader? Is this code reader for any … Have you got the link to the code reader? Is this code reader for any car? I have a peugeot 307



    ebay.co.uk/itm…889?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

    I bought this, I believe as long as it's a <10 y/o petrol or <8y/o diesel it works on all cars

    As others have said, get a fault code reader.
    I dare say it could just be something as simple as a damaged HT lead or spark plug that's causing a partial misfire.
    On my mk2 focus one of the HT leads came off and it was doing something similar to what you described and the engine management light came on.

    andreapedrazzini

    http://www.ebay.co.uk/itm/261093902889?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649I bought this, I believe as long as it's a <10 y/o petrol or <8y/o diesel it works on all cars



    How good is this? My peugeot 307 has also got the engine management light on saying "Anti Pollution fault" the car then only revs to 2900 rpm and also only drives to that rpm before i have to change gears

    probably your Egr valve. same has happened in my corsa and astra. wouldn't worry about it, you can clean it but the light will come back on.

    joshyork

    probably your Egr valve. same has happened in my corsa and astra. … probably your Egr valve. same has happened in my corsa and astra. wouldn't worry about it, you can clean it but the light will come back on.



    Was that aimed at me or the op ?

    joshyork

    probably your Egr valve. same has happened in my corsa and astra. … probably your Egr valve. same has happened in my corsa and astra. wouldn't worry about it, you can clean it but the light will come back on.



    that was what was wrong with mine the egr valve and as my garage dont clean them i had to pay to have a new one put in on my 05 plate renault

    demolisher

    How good is this? My peugeot 307 has also got the engine management light … How good is this? My peugeot 307 has also got the engine management light on saying "Anti Pollution fault" the car then only revs to 2900 rpm and also only drives to that rpm before i have to change gears



    Your car is in 'limp home mode' - and i'll put money on it being your lambda sensor

    Bloody EGR valves, i wanted mine taken out when i had it remapped as they are nothing but trouble!! They gunk up your engine and when they fail they aren't cheap to fix.
    Sadly the tuning company said they don't do it, but there are plenty of garages that do.

    118luke

    Your car is in 'limp home mode' - and i'll put money on it being your … Your car is in 'limp home mode' - and i'll put money on it being your lambda sensor



    These are the codes what showed up when the AA did a diagonstic

    P0088 - Fuel Rail pressure to high
    P1351 - Manufacturer code

    High Fuel Rail Pressure... interesting.
    P1341 According to google is Glow Plug problem . You can test the glow plugs using a multi-meter. (if, of course it is a diesel)

    I wonder if High fuel rail pressure could be an injector problem or something

    118luke

    High Fuel Rail Pressure... interesting. P1341 According to google is Glow … High Fuel Rail Pressure... interesting. P1341 According to google is Glow Plug problem . You can test the glow plugs using a multi-meter. (if, of course it is a diesel)I wonder if High fuel rail pressure could be an injector problem or something



    It is a diesel, 54 plate

    My Vectra did this - threw up a code - had it fixed - threw up a different code - had it fixed again - threw up another code - turns out the ecu itself was knackered so kept throwing random codes - cost me over £700 to have the ecu stripped and refurbed!

    Original Poster

    Broxy

    Post the code here if it works should be a 4 digit code.



    Thanks I will try this tomorrow and update.

    Original Poster

    slamdunkin

    Does your clutch feel normal?



    Yes, it's just accelerating that is causing problems in second gear.

    I bought this ECU reader

    http://www.amazon.co.uk/gp/product/B005Q68E0G/ref=wms_ohs_product

    £9.60 from Amazon
    Then on your smartphone/tablet get Torque or any OBDII reader application and it will check your ECU for fault codes and display them.
    It has helped me countless times with loads of vehicles.

    You have a misfire. With the recent cold weather I reckon a coil pack has failed.

    Original Poster

    Error Code: P0351

    Fitted a new Coil Ignition Pack, brand new part cost £47 including P&P fitted it myself so very pleased!!

    My corsa sxi 2003 engine warning light came on last night for the first time since I got it, had it for a year now. I had it in garage for mot last week got a new exhaust fitted.

    Original Poster

    Pinkc

    My corsa sxi 2003 engine warning light came on last night for the first … My corsa sxi 2003 engine warning light came on last night for the first time since I got it, had it for a year now. I had it in garage for mot last week got a new exhaust fitted.



    My OH had a new exhaust fitted on his Toyota then a week later his engine light came on it was something like
    P0420 error code "Catalyst System Efficiency Below Threshold".
    They said it needs a new sensor but we have been driving it around fine for the last year with no problems.
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. What do you feel like whinging about today?1927377
      2. So Brexit isn't going how a lot of Brexiters thought it would2462
      3. Just heard this...2 ★★★★★★★★★★★★★★ congrats to all on 392k ★★★★★★★★★★★★★★7767370
      4. word association Game74044538

      See more discussions