Groups

    Virgin Hub 3.0 slow

    Just switched to Virgin from BT and have found that streaming is constantly buffering and sometimes does not work, especially on YouTube and Google play. Not very impressed with the Hub 3.0 to be honest and much preferred HH5. Has anyone else had similar issues? Is it worth using the HH5 with the Hub 3 in modem mode?

    13 Comments

    Was just gonna suggest it, you will have to turn off DHCP in the HH5 if it allows, but certainly worth a shot! Also try using an ethernet cable with the Virgin Hub first to make sure its not the line/service itself.

    I have had problems with broadband since i got it from virgin last year with it going off all the time and having to reboot it my year is up now so going to change it they said it was my area I live in was the problem but no one else has this problem good luck i hope you can get it sorted

    sox5

    I have had problems with broadband since i got it from virgin last year … I have had problems with broadband since i got it from virgin last year with it going off all the time and having to reboot it my year is up now so going to change it they said it was my area I live in was the problem but no one else has this problem good luck i hope you can get it sorted


    Ditto constant down time , fixing issue in next two months blah blah. Now with sky and it's been rock solid

    We have virgin hub 3. 2 firesticks going as same time. Youtube, browsing ect. Not a glitch.. I raised hub 3 up on a shelf as height is important apparently. We needed to fit the included firestick extension cord things, as without them fitted it caused problems. Guess it acts as a aerial. No problems though day to day and we have foil backed plasterboard ceilings and solid block walls. Others reported problems though but it's a mystery why

    I have very few problems with mine and it sits on the floor behind the TV

    I went into the settings for mine and changed them to performance over distance and I get 100meg through 5g on WiFi. Live in an old brick wall house. When it was on distance settings it was actually worse. Mine is in an upstairs bedroom

    Is the issue on wifi or direct Ethernet cable?

    First thing use a direct Ethernet cable to a computer if the problem is not there then you may need to look at the wifi settings on the router and possible change wifi channel which may be causing a conflict with neighbours.

    If the problem is there on Ethernet then a call to virgin could fix the issue?

    What speed are you supposed to be getting vs what are you actually getting? Have a look and run a speed test.

    My Virgin Broadband has been really slow, this week not sure why? I was getting a 100 Mbps last week ok.

    Switched to VM Hub 3 couple of weeks ago, from there Superhub 2.0(?), wireless range is greatly increased meaning I dont have to use the wireless extender I had to previously, and 2 sons haven't complained once of online gaming lagging.

    Original Poster

    Performance on both Ethernet and WiFi is slow. First thing I tried was to Ethernet and it still buffers like crazy. I was trying to watch a rented film from Google Play and the quality wouldn't go above 144p!

    Switched to super hub 3 a few months ago after using sh2 for a few years. Not much difference in performance. Possibly better wifi performance all round . No issues with speed now...

    I was under high utilization just as i upgraded to sh3. Vm do not high light the fault on the service page under ur account and will only disclose it via telephone.

    Phone up vm and make sure u are not in a high utilisation area to be sure.

    mike710

    Performance on both Ethernet and WiFi is slow. First thing I tried was to … Performance on both Ethernet and WiFi is slow. First thing I tried was to Ethernet and it still buffers like crazy. I was trying to watch a rented film from Google Play and the quality wouldn't go above 144p!



    Give them a call.

    WDTV123

    Switched to super hub 3 a few months ago after using sh2 for a few years. … Switched to super hub 3 a few months ago after using sh2 for a few years. Not much difference in performance. Possibly better wifi performance all round . No issues with speed now... I was under high utilization just as i upgraded to sh3. Vm do not high light the fault on the service page under ur account and will only disclose it via telephone. Phone up vm and make sure u are not in a high utilisation area to be sure.



    Can you expand on this?
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Best tablet for 100-150? Quid11
      2. Glazing Clay Pots for Drinking22
      3. How are Very for pre-orders ?33
      4. Furniture Sliders45

      See more discussions