Expired

Wanted someone to mod my 360 to 1.51.

5 replies
Found 7th Apr 2009
Ok i need someone trustworthy to mod my 360 to 1.51 £30 inc p+p both ways. Its already 1.5 by the way.

Cheers

  1. Misc
  2. Cinema
Groups
  1. Misc
  2. Cinema
5 Comments

Just out of curiosity what drive is it?

Do you need 1.51 minimum for 3rd wave games?

Abvance;4853273

Do you need 1.51 minimum for 3rd wave games?



yh i wanna know this too

Original Poster

MarzBarz;4853211

Just out of curiosity what drive is it?



Lite-On i believe mate

Abvance;4853273

Do you need 1.51 minimum for 3rd wave games?



Yeah you need it to get the game to boot. I have a PS3 i havent played my 360 for months as the PS3 is better but theres a few i wanna try.

Closed as this is essentially an FS trade/sale/service which we don't allow.

Sorry, commenting is no longer available on this discussion.

Top Discussions
  1. Help: NowTV Movie pass56
  2. What is the best weight training app for iOS please?11
  3. Is this expensive?816
  4. Credit Card Debt Question...915

See more discussions