Groups

    Why Does My Keyboard Not Work Properly?

    Since buying my PC a few years ago my keyboard hasn't been configured properly. My @ key is where the " should be and I don't have the pound sign - all very annoying. Does anyone know why?

    19 Comments

    Check your keyboard or regional settings in Control panel.

    You probably have it set to US

    Original Poster

    No I checked that already

    I have that same problem,i'll look into it when i get home from work

    Your sure it's a UK keyboard? It should look something like this: ]http//en…out

    I assume you're using Windows? If so in the control panel you need to check that everything in 'Regional and Language Options' says UK and that Windows lists the right type of keyboard under 'Keyboard'.

    Hmmmm hang on I'll take a look.

    (looking)

    I've got Vista. I think its the same in XP

    Control panel and then regional and languag options
    There should be a tab for keyboards and languages!

    You mean your keyboard doesnt have a £ sign? or when you press the £ sign it doesnt come up?

    I recently made the mistake of buying a keyboard from Hong Kong ( dont ask me why) so my keyboard doesnt have a £ sign - but when you type shift 3 it comes up.

    This is a regional settings issue with the keyboard. and it could be one of 2 things:

    You have a USA keyboard (with the @ above the 2) and your settings are for UK

    or

    You have a UK keyboard (with " above the 2) and your settings are for USA.

    By default windows (at least up to XP - I haven't installed vista yet) sets itself to be USA

    this seems like a good how-to:
    niles.com/sup…pdf
    (requires acrobat reader)

    wraith.

    Looking at the responses I think the title of the thread should have been "competition to see how many different ways you can come up with to tell me how to do the exact same thing" :giggle:

    howzabout stick a bit of paper on each key with the correct symbol for your layout .... no one suggested that yet! hehe

    robgoldt

    howzabout stick a bit of paper on each key with the correct symbol for … howzabout stick a bit of paper on each key with the correct symbol for your layout .... no one suggested that yet! hehe



    :giggle: :giggle: :giggle: :giggle: :giggle:

    im back from work, on mine its

    Hold shift
    [email protected]
    3=#
    '="

    I went into control panel and into region and language > Regional options is set to united Kingdom> advanced changed that to united Kingdom (even had to put in my windows disk).And its still the same

    the answer has already been posted but I'll try another one.

    try Left ALT+SHIFT:)

    Original Poster

    Yep I'm the same as ad-man! Have no pound sign at all. Language is set to English (United Kingdom), was the same with the original standard keyboard from PC World - my current keyboard is a wireless one from ebuyer. So - no joy with any of the suggested solutions!!!! I'd be grateful for ay mre ideas!!! Oh and as you can see my keys don't always work :-)

    Original Poster

    stora

    the answer has already been posted but I'll try another one.try Left … the answer has already been posted but I'll try another one.try Left ALT+SHIFT:)



    Why did you suggest this??? Its actually worked!! £££££££££££££££££

    Rep added

    finicky

    Why did you suggest this??? Its actually worked!! £££££££££££££££££Rep add … Why did you suggest this??? Its actually worked!! £££££££££££££££££Rep added



    Same here

    Ok, by the sounds of it you've just set your Standards and formats, Location and Language for non-Unicode programs. All of which are language options non of which actually (stupidly) effect keyboard layout.

    As wraithchilds pdf link suggests: In Regional and Language Options go to the languages tab, click on Details, now check what it says in the in there:

    You should have English (United Kingdom), Keyboard, United Kingdom somewhere in the Installed services box and English (United Kingdom) - United Kingdom should be selected as the Default input language.

    Personally I always remove the US settings and disable the language bar too, but that's not necessary.

    stora

    the answer has already been posted but I'll try another one.try Left … the answer has already been posted but I'll try another one.try Left ALT+SHIFT:)



    Thanks Meglomaniac but this actually worked. Would love to know why though!

    Because it's a shortcut to change the keyboard to the next one in the Installed services list mentioned above.

    megalomaniac

    Because it's a shortcut to change the keyboard to the next one in the … Because it's a shortcut to change the keyboard to the next one in the Installed services list mentioned above.



    Thats right. :thumbsup:

    I thought it would be easier to do it that way.
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Xbox One - Buying from Other Regions *WITHOUT* A VPN (Virtual Private Netwo…1851339
      2. Lets hope that there are as few injuries as possible - Parson's Green40210
      3. EasyJet flights for summer 2018 (up until 2nd Sept 2018) will be released o…11
      4. Potential upcoming Argos glitch or buggy app?109

      See more discussions