Groups

    Win 7 Updates keep crashing pc

    Reinstalled Windows due to replacing motherboard and it works until I update.

    The first time I just selected all then it installed fine but when configuring it freezes at exactly 15%

    I ended up reinstalling again but meant to only do a few updates at a time but accidently clicked download all.

    And it has froze again at exactly 15%

    So it sounds like one of the updates is messing up the updates but I cant get into Windows to do a system restore.

    Am I able to get into safe mode and do it that way?

    18 Comments

    Safe Mode with Networking might work.
    .
    Make sure you have all the drivers and such installed before you start doing updates. Also remove any driver updates from the list, Windows 7 defaults to install optional updates that often aren't needed. Hopefully one of those optional updates is the culprit and removing them all will fix your issue.
    .
    I believe you can also choose updates based on whether the PC requires rebooting to finish the installation. It might be worthwhile to install all the ones that install on the fly, reboot, then install the ones that require a reboot. If all else fails, have a look around the interwebs and see if you can get Windows 7 Service Pack 1, this might work better than Windows Update, although I haven't yet tried it.

    Which mobo ?

    Original Poster

    Ok when I go into safe mode it just reverts the changes saying Windows has failed to configure updates

    I have tried updates one by one and random different ones and they still freeze.

    Its a Asus P5B -VM

    Original Poster

    Another post as it wouldnt let me edit, tried 2 tiny security updates and they installed fine so its just having problems with specific updates that need configured before it restarts.

    which KB numbers

    Original Poster

    Will take a while to check, but it seems to install the tiny security updates fine but anything else it wont i.e wont install .net updates, will install drivers fine.

    Scan your hard drive for errors using top box only eg file system errors (or reformat drive at windows 7 install stage

    Something sounds a bit fishy here, almost as if the bigger updates are corrupted but not the smaller ones. The only thing I can think of what would caused this is a dodgy connection to your internet. Are you 100% sure that you have the right drivers doing your network/wifi connection? If you are using WiFi might be worth trying a cable instead to see what happens.

    Original Poster

    Well found out something strange, the updates actually are installing ok its just the configuration crashes

    if I do like 2-4 updates at a time and leave it crashed for like 10 minutes and then remove power and put it back in when I go back into windows it has installed but only if I go onto safe mode first then back into normal.

    I wonder if its a bios issue since its 64 bit windows but only recognises my 3 gig ram as 2.75

    your gfx is using some ram

    Hmm, it might be worth doing a BIOS update, I believe you can use ASUS update software to do it from within Windows, makes it a little easier.
    .
    I am not sure if updates are integrated in current versions of Windows 7, but you can legitimately download real ISO files now to burn a Windows 7 disc. The last few times I have re-installed I have used these and barely had to do any updates.
    .
    See here for more information: techpp.com/200…ks/

    maybe check for bios updates..(see if the read me they enclose to tell you of what they have changed highlights addresses the issue your facing).. Switch from AHCI mode to IDE mode as well..

    Original Poster

    dontasciime

    your gfx is using some ram



    It shouldnt as its a HD4870 512mb GDDR5

    http://img810.imageshack.us/img810/2680/77316291.th.png

    If it is x64 it should be seeing all of his memory right off the bat. If it was 32bit, then fair play.
    .

    dontasciime

    *snip*


    Or this: support.asus.com/tec…714
    It should automatically download the latest and install it.

    32 bit you would still see the full 3 gig (its not got 4 gig in)

    I mentioned your gfx as i assumed you were usign a board that had it built in.. ... speaking of which I'm sure the vm range usually does so disable the onboard GX in bios (eg the init display first option or howvere Asus now word it) in favour of your addon.card..

    Original Poster

    Its sorted now I hope, basically disabled system restore and now it works.

    Dont know why that affected it though.

    It's disabled within seconds of installing on any computer I install.
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Surprise! The HUKD Summer Flamedeer Hunt 2017 **OFFICIAL THREAD** (trading …3501273
      2. Back to school: what's your views on your kids uniform and piercing rules e…1739
      3. Labour MP Naz Shah retweeted calling for abused white girls to shut their m…1940
      4. Just heard this...2 ★★★★★★★★★★★★★★ congrats to all on 392k ★★★★★★★★★★★★★★7764595

      See more discussions