Windows 10 - How to get "Media Devices" to open with File Explorer?

15
Found 26th Jul 2016
I want to open a "Media Device" on a Windows 10 Desktop PC to view it with File Explorer and therefore see the folders/sub-directories/files.

Instead, Windows 10 is adamant it will open the "Media Device" with Windows Media Player (when trying to open with File Explorer). If I try to "Open With" a list of apps, it only allows me to choose Chrome/Edge/Another media player. I simply want to open it/explore the device with file explorer!

Any ideas? Windows 7 would just let you do it.

P.S. Windows 10 Pro if it makes any difference.
Community Updates
AskWindowsWindows 10
15 Comments
What device is it that you're trying to access?

Tried this?

http://i.imgur.com/wED0IZG.png
Usually a of appears asking what you want to do? Ie open to view files etc, as above what are you trying to open? Android phone? Media player etc etc
Sorry was supposed to say usually a box, but this app won't allow me to edit it
I had to download chrome on my desktop and now all my documents open again.
Original Poster
westy125

Usually a of appears asking what you want to do? Ie open to view files … Usually a of appears asking what you want to do? Ie open to view files etc, as above what are you trying to open? Android phone? Media player etc etc



rev6

What device is it that you're trying to access?Tried this?



It's a Canon 750D which I know other people can open via File Explorer to view / copy the raw images onto your hard drive.

I can't even choose what app I want anymore as I clicked OK previously (There were no other better options) These are all the buttons that are visible to me....

https://cdn.pbrd.co/images/1a8OkNCUa.jpg

If I click the button open / or double click, Windows Media Player immediately loads.


Edited by: "Firefly1" 26th Jul 2016
Original Poster
This is such a simple problem yet no simple solution yet Microsoft !!
Do not have the same camera so only talking in general here. If the camera can be mounted as a drive rather than a media device, you should open file explorer click my computer and you should see the camera listed as a drive with a drive letter.

If the camera is not mounted with a drive letter then usually this is down to the camera and not windows. Open the settings on the camera and look for USB connection mode; you should be able to switch between media device and storage modes, set it to storage mode.
Original Poster
Cfcb

Do not have the same camera so only talking in general here. If the … Do not have the same camera so only talking in general here. If the camera can be mounted as a drive rather than a media device, you should open file explorer click my computer and you should see the camera listed as a drive with a drive letter. If the camera is not mounted with a drive letter then usually this is down to the camera and not windows. Open the settings on the camera and look for USB connection mode; you should be able to switch between media device and storage modes, set it to storage mode.



I'm connected over WiFi - or more specifically, the camera is connected to the home WiFi - and I can see it from my desktop that is connected to the same WiFi.

I can view the photos on the camera from the computer via media player, but I want to be able to easily transfer files via file explorer. The computer can certainly 'see' enough information as it's displaying the photos on the desktop via windows media player. However, it's not a drive as it's not directly plugged into the computer.
Equally if I were to have a PLEX server on my home network, I presume I could use file explorer in a similar manner. The only difference is this being a camera that is capable of doing this.

It's a problem with Windows 10 rather than anything else or the set-up of my computer - this is certainly do-able as i've seen other people have.

Edited by: "Firefly1" 26th Jul 2016
Download VLC player and make that your default program to use. Press win key + x then go to control panel/programs/Default Programs.
Edited by: "RiverDragon8" 26th Jul 2016
Again talking in general here. For file explorer to see your camera as a network storage device, the camera itself needs to be broadcasting as a Windows host with a shared folder (or sometimes called Samba host). Assuming the camera is doing this, you should open file explorer and click networks and should see the camera there, clicking on the camera should then show the shared folder.

If the camera does not show as a network host, then I have ran out of suggestions without having the actual camera to work with. I can only suggest to check the camera manual to ensure it is functioning as a network host.

Hope you get it sorted.
Original Poster
Cfcb

Again talking in general here. For file explorer to see your camera as a … Again talking in general here. For file explorer to see your camera as a network storage device, the camera itself needs to be broadcasting as a Windows host with a shared folder (or sometimes called Samba host). Assuming the camera is doing this, you should open file explorer and click networks and should see the camera there, clicking on the camera should then show the shared folder.If the camera does not show as a network host, then I have ran out of suggestions without having the actual camera to work with. I can only suggest to check the camera manual to ensure it is functioning as a network host.Hope you get it sorted.



The camera is broadcasting itself with DLNA protocol/setting.
This is because Canon decided to remove the direct Windows WiFi option from the 750D to differentiate their products. However Canon forum people have discussed what I am trying to do as a workaround....I feel so close yet so far! Will try your tips above now
Edited by: "Firefly1" 26th Jul 2016
Original Poster

This is somebodys guide, and they gloss over the DLNA bit...

You CAN use Wi-Fi to transfer your pictures from your T6s/T6i to your … You CAN use Wi-Fi to transfer your pictures from your T6s/T6i to your computer.Press: Menu>wench1>Wi-Fi/NFC choose "enable"Go back to the menu, select "Wi-Fi FunctionSelect the monitor picture, "View images on DLNA devices"You are given 3 options, Choose "find network", OK is then highlighted, select it.Your camera then looks for wireless networks, and produces a list. Select your network, and hit "ok".At this point, it asks me to enter my network password: 1. Enter 8-63 ASCII charactors 2. Enter 64 hexadecimal char.If you have chosen a different level of security for your wireless network, things will be different.You are presented with a mini keyboard, enter your password, select "ok"The next page is "ip address set", select "auto"After a few seconds of "busy", you get the "Connection" screen.That's it, you're connected to your network. Two options are listed:1. Disconnect, exit --select when your done 2. Confirm set. --select gives you access to 4 pages of your network connection settings. Put the camera down, go to your computer. Windows 10, should be similar for others1. select window (start) button>"file explorer" 2. select "this PC" from the list.Under "network locations" there is a black, square icon, with the letters "EOS" Labeled, "Canon EOS Rebel T6s" Double click the EOS icon and then "SD folder">> "100 canon" >>(numbered picture folders. That's it, your pictures. Once you setup your connection you can choose it again without entering all the info over again.

Original Poster
Cfcb

Again talking in general here. For file explorer to see your camera as a … Again talking in general here. For file explorer to see your camera as a network storage device, the camera itself needs to be broadcasting as a Windows host with a shared folder (or sometimes called Samba host). Assuming the camera is doing this, you should open file explorer and click networks and should see the camera there, clicking on the camera should then show the shared folder.If the camera does not show as a network host, then I have ran out of suggestions without having the actual camera to work with. I can only suggest to check the camera manual to ensure it is functioning as a network host.Hope you get it sorted.



Got it sorted
Darn this is confusing.

If I go via "Network" (in file explorer), only windows media player will open.

If I go via "This PC" (in file explorer) and, below my hard drives, there is a list of "Network Locations", I can access the files via file explorer.

How peculiar! Thanks for all your help
Edited by: "Firefly1" 27th Jul 2016
Great, nice to know it works.
Could always use a card reader. I have the 750d and always take the card out to transfer pictures. It's faster, more simple and more reliable.
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Discussions

    Top Merchants