Windows 10 - No Internet, Secured

92
Found 6th Dec 2016
So i can connect to my WiFi router, but no internet on my laptop. The WiFi signal icon has a yellow ! icon on top of it.

I've tried uninstalling the WiFi adapter and restarting the router but still no luck.

All my other devices can connect with no issues.

Any ideas? Thanks.
Community Updates
92 Comments
I had this before but can't remember the life of me how I fixed it...it drove me crazy. I think it was a setting in the network section..was like a slider...it tell you what I'll go have a look
I had this same issue. Mine was windows 10 conflicting with the wifi drivers. They had to be manually updated due to the window 10 updates constantly screwing it up
Original Poster
Thanks, been trying to sort this all night ffs
Original Poster
Can't even connect via ethernet either.

Diagnostics keeps saying doesn't have a valid IP configuration
Try right click on Wi-Fi icon and click troubleshoot
If it gets to rest wireless adaptor you will be reconnected
Common problem with win10
Original Poster
sowotsdis

Try right click on Wi-Fi icon and click troubleshootIf it gets to rest … Try right click on Wi-Fi icon and click troubleshootIf it gets to rest wireless adaptor you will be reconnectedCommon problem with win10



​Thanks, see above. No luck.
found out mine was due to mcafee and fast boot. once I switched both off it worked fine. have you tried to connect it via cable?
superfreddy

Can't even connect via ethernet either.Diagnostics keeps saying doesn't … Can't even connect via ethernet either.Diagnostics keeps saying doesn't have a valid IP configuration



​do you use vpn?
Original Poster
No VPN
Restart router?

EDIT my bad you tried that.
Edited by: "Pagals" 6th Dec 2016
have you set yourself a static IP?
try cmd and typing ipconfig to see if you are getting an IP address from router either land or wifi
Happened to me use this window 10 wifi problem
also make sure that you haven't switched the wifi button to off by accident as there maybe a button on your laptop!
Original Poster
darkfusion187

try the following … try the following link:-http://windowsreport.com/wi-fi-valid-ip-configuration-windows-10/Never seen this before...crazy!



​Tried most of that too. I haven't changed anything to cause this. Was working fine this morning.
Try:
Power off your W10 PC, Laptop or gizmo that has problem.
Turn off the mains supply to your router for 30 seconds.
Power on and wait for the router to reboot and connect to your wifi stuff that works ok.
Power on the W10 kit.
(I had a new ChromeCast 2 that wouldn't/couldn't successfully connect until I rebooted my Virgin Superhub
Connected in a flash afterwards. No problems since.)
Original Poster
buckiebull

Happened to me use this window 10 wifi problemalso make sure that you … Happened to me use this window 10 wifi problemalso make sure that you haven't switched the wifi button to off by accident as there maybe a button on your laptop!



​But can't connect via ethernet either.
God dam! This is winding me up now. Just a thought did you try Microsoft fix it program off there website? It's quite good at fixing these things
Happened to me a couple of days ago. Restarted router and laptop but just wouldn't connect. So i just tethered from my mobile. But in the morning laptop and internet was fine. I only just seen this issue in the last week. Before I never experienced it.
Original Poster
I can't download anything as the laptop can't get internet. Don't have another PC to download it.
A long shot but your DHCP server on the router may have run out of addresses.

Go into your router settings and see if you can increase the amount of devices within a section called DHCP.

If that doesn't work try setting a manual IP address just to eliminate the problem. A DHCP server will aloocate your device & IP address which expires after a set amount of time. On your laptop it may have expired but not expired on your other devices, hence the issues only happening on your laptop.

Original Poster
I have a BT Smarthub. No idea how to do it via that.
Original Poster
I did split my network last week to 2.4 and 5.0, but that's been ok on my laptop recently.
Try:
Via Command Prompt in Admin mode
Netsh
winsock reset
Reboot
Original Poster
Publix

Try:Via Command Prompt in Admin modeNetshwinsock resetReboot



​Done, no luck!
This happened to me a couple of times on moving my laptop from upstairs to downstairs. Connected wirelessly and router downstairs. Went frantic looking for a solution. In the end I did a system restore and it worked again. Don't know why!
superfreddy

​Done, no luck!


I have the same issue, not spent any time trying to fix it yet but found this I was going to go through answers.microsoft.com/en-…e09
Also use McAfee.....
I had this and I put my first through my laptop so had 2 go and buy a new 1 the next day which put me £469 outta pocket so whatever you do keep calm lol
Not an HP by any chance is it.
It only happens using win10 and only recently did it start playing up
Microsoft release updates and it's these that mess up the system sometimes.
The last time it conflicted with McAfee & AVG so I got rid of both and now use windows defender
Original Poster
Smartguy1

Not an HP by any chance is it.



​Yeah it's a HP
Do you have the latest drivers for the ethernet and wifi?
Original Poster
Nothing's changed in terms of the drivers though. Was fine up until now.
Original Poster
Nope, but thanks.
Banned
right click your wifi icon in bottom right 'open network and sharing centre'
under your active networks or the one you are trying to connect to does it say 'public network' ?
Original Poster
Only thing left to do now is either reset the smart hub or laptop to factory settings.
longshot..Some HP laptops have a physical switch on the side to enable/disable wifi.
Original Poster
superfreddy

Only thing left to do now is either reset the smart hub or laptop to … Only thing left to do now is either reset the smart hub or laptop to factory settings.



​No it doesn't
Original Poster
djfluff

longshot..Some HP laptops have a physical switch on the side to … longshot..Some HP laptops have a physical switch on the side to enable/disable wifi.



​No, wifi is connected. Just no internet. Even via ethernet
Banned
superfreddy

​No it doesn't



sorry why are you replying to yourself? it says private network ?
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Merchants