Windows Vista search

if you click the start button then start typing and hit enter it does a search, if you type CMD it will launch the Command line box etc. However mine doesnt do that nany more, so ive inadvertantly changed a setting somewhere.. what have i done and how can i make it better :P

21 Comments

Open explorer ( Windows E )
click on " Organise " top left
click on " folder and search options"
click search tab
restore defaults

Original Poster

tonyg1962;7182011

Open explorer ( Windows E )click on " Organise " top leftclick on " … Open explorer ( Windows E )click on " Organise " top leftclick on " folder and search options"click search tabrestore defaults



nope didnt work.

when i type CMD it still does a search for it instead of launching the command line
Have some rep anyway for the help :P

what does it do now? does it say start search?

Original Poster

it pops up with a window having just searched for the term CMD rather than opening the command line as it used to

When you click on windows does the search box say " search programmes and files " ?

Original Poster

tonyg1962;7183123

When you click on windows does the search box say " search programmes and … When you click on windows does the search box say " search programmes and files " ?



if i click the start button it just says start search in the box.

Assuming nothing works it sounds like your path environment variable has gotten messed up, it's under the advanced tab of advanced system settings in vista. Hit environment variables and then check what the path one in the system variables section is set to, it should be something like: %SystemRoot%\system32;%SystemRoot%; with a load of other stuff afterwards added by badly behaved programs.

Original Poster

EndlessWaves;7183727

Assuming nothing works it sounds like your path environment variable has … Assuming nothing works it sounds like your path environment variable has gotten messed up, it's under the advanced tab of advanced system settings in vista. Hit environment variables and then check what the path one in the system variables section is set to, it should be something like: %SystemRoot%\system32;%SystemRoot%; with a load of other stuff afterwards added by badly behaved programs.



where in the system variables?
im seeing several entries. The one labled path has the entry set as:

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files (x86)\QuickTime\QTSystem\

Banned

this is how it has always worked for me (it is a search option after all).

you have to ckick RUN, then type CMD

Not exactly what you asked but this may be easier:

Start
All programs
Accessories
Command prompt
Right click and you can pin this to the Quick Launch or Start menu.


Gets round the problem, but doesn't fix exactly what you asked.:thumbsup:

Original Poster

csiman;7184560

this is how it has always worked for me (it is a search option after … this is how it has always worked for me (it is a search option after all). you have to ckick RUN, then type CMD



in vista there is a quick launch feature with the start menu, it acts as a sudo run box, so if you type CMD it pops up with the command prompt, Notepad will pop up with notepad etc.

and its irritating its not working!

any more ideas?

Any chance the Windows Search service has been disabled? Right click My Computer - Manage - Services and Applications - Services - Windows Search. Even if it's not disabled, try restarting it...see if that works.

Original Poster

gaanja;7186201

Any chance the Windows Search service has been disabled? Right click My … Any chance the Windows Search service has been disabled? Right click My Computer - Manage - Services and Applications - Services - Windows Search. Even if it's not disabled, try restarting it...see if that works.



thanks i will try that when i get home.

Mine has always acted the way yours acts now, so that maybe the default, hence restoring defaults not sorting it.

I type in cmd then just hit enter, its only an extra keystroke, but will be interested to see if you can work out the problem, I wouldn't mind mine running straight away.

Banned

ChipSticks;7188453

Mine has always acted the way yours acts now, so that maybe the default, … Mine has always acted the way yours acts now, so that maybe the default, hence restoring defaults not sorting it.I type in cmd then just hit enter, its only an extra keystroke, but will be interested to see if you can work out the problem, I wouldn't mind mine running straight away.


no - his doesnt work like yours at all. He wants it to though.

Cant see what wrong with just pinning it to the start menu myself. Only 2 clicks to run it then and no typing

Original Poster

gaanja;7186201

Any chance the Windows Search service has been disabled? Right click My … Any chance the Windows Search service has been disabled? Right click My Computer - Manage - Services and Applications - Services - Windows Search. Even if it's not disabled, try restarting it...see if that works.



Nope that didnt work

csiman;7189270

no - his doesnt work like yours at all. He wants it to though.Cant see … no - his doesnt work like yours at all. He wants it to though.Cant see what wrong with just pinning it to the start menu myself. Only 2 clicks to run it then and no typing



its not just CMD i launch this way, i launch a load of other apps as well, its just very convenient and i want it working again! *throws toys out of pram*

any other ideas?

Does a standard run box (Win+R) still work correctly?

Original Poster

Johnmcl7;7190971

Does a standard run box (Win+R) still work correctly?



yep that pops up and runs just fine

Banned

google group policy restrictions. probably set something to prevent access in this manner

Original Poster

worked it out! i had search programs unchecked in the start menu options for some reason!

thanks for the help everyone!

Good one. Will remember the fix for future!
Post a comment
Avatar
@
    Text
    Top Discussions
    1. GOT Leaks again415
    2. Stop everything, Nutella is bringing a biscuit snack to the market - Metro1312
    3. Just heard this...2 ★★★★★★★★★★★★★★ congrats to all on 392k ★★★★★★★★★★★★★★7763948
    4. What an absolute disgrace2150

    See more discussions