EXPIRED

wireless router help.

hi im with virgin media and have always used a wireless router, we had a d-link one up until a few weeks back but it broke. we have now bought a belkin N wireless router and seem to be having trouble, every now and again it keeps showing connected to the router but no internet access, weve got a password on it so no one can be using our wireless, i know its not a problem with virgin as when i plug the ethernet cable straight into my laptop i get a connection to the internet, does anyone have any idea of what i can do to stop it losing the internet connection.

7 Comments

Had 3 belkin routers through time - took all 3 back.

Had the same problem the "N" one I had - kept on losing connection to the internet.

Original Poster

i never had a problem with the d-link one, think i will have to take this one back, its just annoying when it loses connection, i got it from pc world so i bet i have trouble returning it as im not sure where the reciept is but hopefully i can print off my bank statement to prove i got it from there.

Try going to the router home page (192.168.2.1) and changing the channel number. Belkin suggested I do this when I had the same problem and it worked for me.

Original Poster

lady111

Try going to the router home page (192.168.2.1) and changing the channel … Try going to the router home page (192.168.2.1) and changing the channel number. Belkin suggested I do this when I had the same problem and it worked for me.



hi i havent a clue about stuff like this lol how will i know what channel number to change it to.

I had the same problem, Belkin Routers are useless and the Help desk whilst reasonably helpful were unable to solve problem- (did not work with O2 - you would think they could have solved that!!). They eventually replaced with another but new one did not work either. JUST DONT BUY BELKIN ROUTERS!!!

pink-ka

hi i havent a clue about stuff like this lol how will i know what channel … hi i havent a clue about stuff like this lol how will i know what channel number to change it to.


Somewhere in the routers setup will be a setting for the WiFi channels. Usually it's preconfigured to "Automatic" but you can also force any channel from 1 to 11.

The channels overlap each other, so there's only three genuinely distinct channels: 1, 6 and 11. Channels 2-5 and 7-10 are only intended to be useful in other countries.

So pick a number (1, 6 or 11) and try it for a while. If you still get problems change it to one of the other two numbers.

turn WPS off
Post a comment
Avatar
@
    Text
    Top Discussions
    1. Xbox One X pre order £449.99 @ Game (out 9th Nov)2451
    2. How dangerous is Donald trump?1960
    3. ❅☁☁❅ I want☼to talk☼about the☔WEATHER☔no politics☃no religion❅☁☁❅18846137
    4. I banned myself from HUKD for 3m, I saved so much money!2745

    See more discussions