Xbox 360 STILL won't play compatible Xbox games after update is applied manually and confirmed. Any suggestions?

Just got several Xbox games that should be compatible with the Xbox 360. Have tried four of them now -- TC's splinter cell: pandoras tomorrow / halo 2 / doom 3 / medal of honour: frontline -- but all come up with the message "This game could not start. Please download the game again", even though I am signed into my LIVE account.

They are all on the compatiblity list and according to the Xbox site as long as I'm signed in, the update to get them working should automatically start when one of the Xbox discs is inserted. xbox.com/en-…htm

I have a 20GB HD with plenty of space so that's not the problem.

The 360 is flashed with iextreme 1.4 - could that be the problem?

My Xbox LIVE account is a one month free trial - could THAT be the problem?

I know I can download the update and apply it by CD but don't have a CD at hand so thought I'd ask here before buying some to see if there is anything else you can think of. Thanks.

7 Comments

should just work, could be the flash like u say. ive never had that problem.

Original Poster

andy108uk;2527859

should just work, could be the flash like u say. ive never had that … should just work, could be the flash like u say. ive never had that problem.



yeah, well, looks like I'll try the download on the the cd and if that doesn't work I'll be selling the xbox games that have just arrived. :roll:

Original Poster

Just to say that I downloaded, burned to disc and applied the MS update this morning. The update was confirmed on the console but still none of the games work. The message "This game could not start. Please download the game again" comes up every time.

It seems it must be the flash, as I have no other problems. Contacted MS under another email address and they said they will need to investigate the matter further... Erm.... no thanks! Game over methinks.

Are the games "backups"?
Also, what cable do you use to play the games?
Xbox games only work with scart or the cable that comes with a 360, no go with VGA for example.
Last year i had my first xbox game and wanted to play it on the 360.
Same error you got. Then I found out it was because of the display (I´m using VGA), so I used the cable that came with
the console and it worked fine. Stinks IMO that you have to use a different cable for xbox games...

Btw, It´s never the flash as it does´t change anything at all on the console
other than enable you to play backups

why dont u just be signed onto Xbox live and put the disk in... it will auto update and should play fine.

As far as i can remember it updates for every disk you play. Doesnt do like a big update so you can play them all.

Original Poster

Thanks for the info guys but in the meantime I've had the RROD - so it's going from bad to worse. Info on the thread where I bought it. Looks like this problem was just part of the buildup to this little disaster... hotukdeals.com/ite…iu/

EDIT: but on the xbox games issue, thanks Tanya, might have been because I'm using VGA cable to monitor, but like I said, may all be academic now if I don't get this sorted...

Yeah I just saw your other thread.
Stinks...we had a RROD in march this year...very annoying.
You getting it fixed or will you sell it on ebay (or on here for less of course lol) and buy a new falcon console?
Post a comment
Avatar
@
    Text
    Top Discussions
    1. love affairs1649
    2. The obvious next step become Ken then become Barbie1525
    3. Important info for Ryanair customers1825
    4. word association Game73944491

    See more discussions