Xperia SP Flash to stock firmware

14
Found 28th Mar 2015
Hi, i had a sony xperia sp which i installed cyanogenmod 11 but now as i got an s4 i need to take the cyanogenmod to sell it to cex but they won't accept it as it is
I need to make the phone factory (original rom, no root/superuser and no custom recoveries)
can someone tell me where to find a firmware and a flash tool for it please and instructions.
Thanks

Shared Via The HUKD App For Android.

  1. Ask
  2. Xperia
Groups
  1. Ask
  2. Xperia
14 Comments

Original Poster

If someone can also tell me how to do it on a S4 it'll help but don't really need to at this minute

go and look on XDA website I'm sure you will find a guide there

Original Poster

I've got a flashtool and firmware but when I put the Xperia into Fastboot mode it'll come straight out and go to the charging screen.

Do you do it like this?:http://www.theandroidsoul.com/wp-content/uploads/2014/01/1200x750xSony-Xperia-Devices-Flash-Mode.png.pagespeed.ic.f1a_JFho6F.webp

• Power down the SP.
• Press and hold the Volume Down button
• Connect to your PC using a USB Cable while holding down the Volume Down button on your Xperia SP
(Before plugging in the USB cable on your Xperia SP make sure that the other end of USB cable is already connected to the PC.)
• Your Xperia SP should be in Flash Mode now and the device’s LED light should turn into Green.

Original Poster

SupremeJaguar

Do you do it like this?:• Power down the SP.• Press and hold the Volume Do … Do you do it like this?:• Power down the SP.• Press and hold the Volume Down button• Connect to your PC using a USB Cable while holding down the Volume Down button on your Xperia SP(Before plugging in the USB cable on your Xperia SP make sure that the other end of USB cable is already connected to the PC.)• Your Xperia SP should be in Flash Mode now and the device’s LED light should turn into Green.


Yeah did that it went green my computer recognized it for 1 minute and it rebooted itself

hamzabaig

Yeah did that it went green my computer recognized it for 1 minute and it … Yeah did that it went green my computer recognized it for 1 minute and it rebooted itself



Take a look at this: forum.xda-developers.com/sho…952

Also this: http://xperiafirmware.com/8-firmware/37-sony-xperia-sp-c5303
Let us know how it goes!

S4 you need to use odin to flash firmware which you can find online at for example, Sammobile.

Original Poster

SupremeJaguar

Also this: … Also this: http://xperiafirmware.com/8-firmware/37-sony-xperia-sp-c5303Let us know how it goes!


The phone is now stuck on the sony logo

Heres what it says on Flashtool;

28/040/2015 12:40:00 - INFO - Unable to read from phone after having opened it.
28/040/2015 12:40:00 - INFO - trying to continue anyway
28/013/2015 16:13:21 - INFO - Start Flashing
28/013/2015 16:13:22 - INFO - Processing loader.sin
28/013/2015 16:13:22 - INFO - Checking header
28/013/2015 16:13:22 - ERROR - Processing of loader.sin finished with errors.
28/013/2015 16:13:22 - INFO - Ending flash session
28/013/2015 16:13:22 - ERROR - Error in processHeader : 5 : Access is denied.
28/013/2015 16:13:22 - ERROR - Error flashing. Aborted
28/013/2015 16:13:26 - ERROR - Drivers need to be installed for connected device.
28/013/2015 16:13:26 - ERROR - You can find them in the drivers folder of Flashtool.
28/013/2015 16:13:37 - INFO - Device disconnected

hamzabaig

The phone is now stuck on the sony logoHeres what it says on … The phone is now stuck on the sony logoHeres what it says on Flashtool;28/040/2015 12:40:00 - INFO - Unable to read from phone after having opened it.28/040/2015 12:40:00 - INFO - trying to continue anyway28/013/2015 16:13:21 - INFO - Start Flashing28/013/2015 16:13:22 - INFO - Processing loader.sin28/013/2015 16:13:22 - INFO - Checking header28/013/2015 16:13:22 - ERROR - Processing of loader.sin finished with errors.28/013/2015 16:13:22 - INFO - Ending flash session28/013/2015 16:13:22 - ERROR - Error in processHeader : 5 : Access is denied. 28/013/2015 16:13:22 - ERROR - Error flashing. Aborted28/013/2015 16:13:26 - ERROR - Drivers need to be installed for connected device.28/013/2015 16:13:26 - ERROR - You can find them in the drivers folder of Flashtool.28/013/2015 16:13:37 - INFO - Device disconnected



Seems like you've not installed the drivers?

Original Poster

I have installed the drivers but thanks for your help I have done it now

hamzabaig

I have installed the drivers but thanks for your help I have done it now



What was the solution?

Original Poster

SupremeJaguar

What was the solution?



Well, it took 11 hours but I didn't sit there and wait I went out and left it running i just re installed the drivers and started it again took a 300 mile trip by road and came home to see it was working and it said the timings of it on the flashtool, Thanks for your help mate

hamzabaig

Well, it took 11 hours but I didn't sit there and wait I went out and … Well, it took 11 hours but I didn't sit there and wait I went out and left it running i just re installed the drivers and started it again took a 300 mile trip by road and came home to see it was working and it said the timings of it on the flashtool, Thanks for your help mate



Anytime!
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Merchants