Xperia Z1 Network Issue

Hi,
I have had my Sony Xperia Z1 Compact for around two years one of them years it's spent it's life in a draw since I moved to the iPhone. I recently got it out and reset it to give it to a family member the phone works fine but when I insert a sim card, it says 'Sim card inserted restarting device' or something along those lines then after the phone turns on, it says 'No sim - No service' can someone please help. The phone is 100% unlocked from my memory and I have also checked online where they say type #*#7378423#*#* (*#*#service#*#*), then go to service info>simlock. There are 5 numbers, if all of them are 0, then there is no sim lock which is practically my case.
Can someone please help.
Thank you.

3 Comments

More or less try everything listed on the below article. Presuming also this has been with a known working,active aim card.

fix no sim error on Android





cecilmcroberts

More or less try everything listed on the below article. Presuming also … More or less try everything listed on the below article. Presuming also this has been with a known working,active aim card. fix no sim error on Android



​meant SIM card not aim lol. Stupid app brings error each time I try to edit.

Take the sim card out and rotate 180 degrees and insert back in.
Post a comment
Avatar
@
    Text
    Top Discussions
    1. Best student laptop max budget £300?22
    2. Kia Rio 1.0 T-GDI (petrol) vs Rio 1.4 CRDI (diesel)55
    3. tcb what's the longest anyone has waited for a payout?710
    4. Car Leasing Deals (Audi, Golf or Scirocco)34

    See more discussions