Posted 18 January 2024

Anyone having issues with Turkish Epic Games account

Was going to purchase some games today and I've been getting this error, wondering if anyone else has got it, or if purchases are going through fine still. I'm using my Monzo account with NordVPN, also tried Opera's Pro VPN
Had this happen before around a year ago but it eventually started working again.

One thing I noticed while playing around is that connecting to Turkey with NordVPN through P2P and using a private tab (so logged out) is giving me prices in $ instead of TRY, it looks to be the same pricing as Argentina? So I wonder if something is whacky with NordVPN and I've kinda locked myself out of purchasing but would still like to know if anyone else is having issues
Community Updates
New Comment


sorted by
's avatar
  1. jameshothothot's avatar
    Hi I purchased a lot of these in recent weeks. Had to run a VPN or DNS changer on the web browser when purchasing. All prices in TRL. Last bought a week ago.

    Surfshark and controlD worked for me. (edited)
    MythicStream's avatar
    Yeah I was also able to purchase recently, was able to buy on the 16th, but yesterday was unable to. Think it may be some VPN or routing shenanigans going on, because if I VPN to Turkey and log out of Epic all the currencies change to Dollars and it looks to think I am in Argentina and then because I was trying so much it may have blocked me from buying
  2. jameshothothot's avatar
    Hi has anyone tried this again recently? I see lunar new year sale is on!

    just tried this really cheap game with surfshark germany on app and no joy (revolut)

    tried edge controlD - same (edited)
    DeejDan's avatar
    Still no luck. I was able to get a purchase to go through shortly after this post started using Razer Gold. Sometimes it'll let me go to the Razer page but sometimes it won't. Plus there's an extra 10% fee and then buying the Razer Gold gift cards are usually a bit more expensive than the exchange rate so it adds up. It still ends up being cheaper, but if the payment doesn't go through you're kinda stuck with the Razer Gold being in your account. I only tried it out since I had some Epic points to use up so the DLC I wanted only cost me an extra 50p real money.

    It does look like the old easy method is dead now (edited)
  3. enfluence1's avatar
    Same with me with vpnunlimited and windscribe,

    same issue as last year, might just be a temporary thing
    MythicStream's avatar
    Hope so mate! If I have any luck I'll try and come back to this discussion and update (edited)
  4. DeejDan's avatar
    Having the same issue. Worked fine a week or two ago during the sale, but I'm unable to buy anything now.
    MythicStream's avatar
    What VPN are you using when doing this? Also if you log out of your account and turn the VPN on what currency is being displayed on Epic?
  5. half_empty_soul_'s avatar
    so bye bye epic, there is no chance I will buy anything for UK rip off prices
  6. crazygoldfish's avatar
    Looks like the dream is over.

    i tried a really cheap game and it worked.

    tried home world 3 and didn’t work with my fups
's avatar