Posted 26th Nov 2022
I recently bought the disc version of MW2.I did the standard installation and then proceeded to download the multiplayer part of it(7.03 GB).It downloaded fine but I’ve just come back to it to see its “Not Installed”.This has happened twice now and I don’t know what I’m doing wrong if anything.I have plenty of space on my HD.I’ve attached a screenshot.
Please help
Community Updates
New Comment


sorted by
  1. Avatar
    It used to do this on Mw19 was a bug. Maybe they've encountered the same one with this? I'm on PS5 and touch wood no issues.
    Are you storing it internally or external HDD?
    Maybe delete the whole thing and start again if you've fast internet
    It’s stored internally and I tried the deletion of everything and it still won’t work.It seems others are experiencing similar problems but have yet to have a solution
  2. Avatar
    Further to that I’ve looked on the notifications menu on the ps4 and it shows the multiplayer pack add-on was “Installed” but when I click on it it brings me back to the screen I uploaded on the original post.
    Isn't that just the DLC that's installed?. When I see "content pack" I just assume that it just a map or something, not the full multiplayer.

    Do you have enough space? you need at least twice the size to install. (edited)
  3. Avatar
    @scorpio.iscariot did you allready find A fix for this issue? 
    I have the same problem and have allready tried everything but nothing seems to work. 😞
    Sorry.I tried it for the 4th time this afternoon and it’s still not working
  4. Avatar
    Has anyone got fix for this?
Top Merchants