Posted 3rd Jan 2022
Whenever I leave the house and come back the wifi on the phone does not reconnect to my home wifi, I have to click it to connect it again everytime? Any ideas how to resolve?

Thanks
Community Updates
Ask
New Comment

29 Comments

sorted by
Avatar
  1. Avatar
    WiFi setting

    Tap on your home network
    Is the connect automatically on? (edited)
  2. Avatar
    I have this issue on my redmi 8.

    In addition I can't connect to wifi 6 routers- phone was released 2019 though so that's understandable.

    But with pre wifi 6 routers it exhibits the same behaviour as yours.
  3. Avatar
    Yes could be. I'd try your old router if poss.
  4. Avatar
    Make sure Randomized MAC address is turned off.
  5. Avatar
    BigDom04/01/2022 12:14

    Make sure Randomized MAC address is turned off.


    Good suggestion.

    Just tried- no difference unfortunately.
  6. Avatar
    itlotb04/01/2022 14:57

    Good suggestion.Just tried- no difference unfortunately.


    Was it on or off. If it was on and you switched it off you have to connect twice. But that's if it was switched on originally.
  7. Avatar
    BigDom04/01/2022 16:32

    Was it on or off. If it was on and you switched it off you have to connect …Was it on or off. If it was on and you switched it off you have to connect twice. But that's if it was switched on originally.


    It was already off. But I did the forget network. Reboot the router. Then I made sure it was still off before I connected and entered the password.
  8. Avatar
    You're doing just fine and I understand that this network stuff is new for you.
    In the router settings can you 'restart' the router. Do NOT reset. (I,m trying to keep it simple).
  9. Avatar
    Author
    BigDom04/01/2022 21:03

    Does your phone auto connect in the supermarkets,restaurants,school or …Does your phone auto connect in the supermarkets,restaurants,school or work where you have signed on before.


    I will test this tomorrow as the only connection I have on my phone so far is my home, I will go to my mothers and connect it to hers and see if it does the same thing as she is with a different provider than me and also only has broadband and not fibre, not sure that would make any difference though. I will let you know how I get on sometime tomorrow and many thanks for your help, its very much appreciated.
  10. Avatar
    Thanks for the update. It's starting to seem like power management setting somewhere on you device. It's actually in the most obvious place on your phone but you will only find it when you're not searching for it.
    O.K one more try and I'll leave it. goto Wi-Fi -> Wi-Fi assistant -> Select best network automatically (Turn Off).
    Best of luck.
  11. Avatar
    Author
    Thanks Bigdom

    I'll just put up with it and hope some day it sorts itself or I find a resolution,

    All your help was very much appreciated.
  12. Avatar
    Author
    It was on when I read up about this issue and one person mentioned disabling it so I did and it didn't help so I re-enabled it but it still doesn't work? I have also reset network settings and reapplied wifi settings and also rebooted router? Thanks.

    One thing I want add is when I rebooted the router it reconnected to router BUT I noticed the icon stayed toggled on it were as when I go out it toggles off meaning I have to retoggle on? (edited)
  13. Avatar
    Author
    My router is relatively new (Plusnet) so not sure if that could be the problem? Its just anoying having it toggle off whenever I leave the house?
  14. Avatar
    Author
    Sadly I cant as it was faulty! I wonder if theres a way of checking if the thing you mention is the problem?(Not sure what it means btw lol)
  15. Avatar
    Author
    Mines off its set to use device mac. I wonder if this issue is device wide or select ones? Deciding if I should send back? Thanks
    Avatar
    try emailing xaomi customer services .
  16. Avatar
    Author
    @itlotb Have you changed anything on your phone since you got it? One thing I should have mentioned was I uninstalled some apps and disabled some others using the YT video below, I haven't removed or disabled anything other than whats in that video, if you go to 5 mins 40 you will see exactly what I done.

    If I do a factory reset will these all auto install again? If so I might just do that and see how it goes. Thanks

  17. Avatar
    1spoon104/01/2022 17:34

    @itlotb Have you changed anything on your phone since you got it? One …@itlotb Have you changed anything on your phone since you got it? One thing I should have mentioned was I uninstalled some apps and disabled some others using the YT video below, I haven't removed or disabled anything other than whats in that video, if you go to 5 mins 40 you will see exactly what I done.If I do a factory reset will these all auto install again? If so I might just do that and see how it goes. Thanks[Video]


    No. Mines as it came. I did a factory reset a week or so ago. Didn't help.
  18. Avatar
    So you guys have 'selene' with version V12.5.11.0.RKUEUXM.
    If I'm correct?
  19. Avatar
    Author
    I have MIUI Global 12.5.14.0 RKLEUXM if that helps? Android version 11 RP1A200720.011 (edited)
  20. Avatar
    1spoon104/01/2022 18:20

    I have MIUI Global 12.5.14.0 RKLEUXM if that helps? Android version 11 …I have MIUI Global 12.5.14.0 RKLEUXM if that helps? Android version 11 RP1A200720.011


    1spoon1 and itlotb.
    Are both of you 'rosemary' version 2.5.14.0 RKLEUXM.
    You stated in you question that your phone is a redmi 10.
    You firmware say Redmi Note 10S. please clarify, its getting confusing for me.

    There's the
    Redmi 10
    Redmi note 10S
    Mi 10
    all using MIUI.

    Will try to help when I get more spare time.
  21. Avatar
    Author
    So sorry, yes its the Redmi Note 10s! My bad.
  22. Avatar
    1spoon104/01/2022 19:35

    So sorry, yes its the Redmi Note 10s! My bad.


    No problem.
    Does your router have both 2.4Ghz and 5Ghz bands, and can you separate them into different SSID's. ( NOT 5G) (edited)
  23. Avatar
    Author
    I just logged into router and it shows 2.4ghz and 5ghz wireless networks and whats connected to them but I wouldn't have a clue how to do what you mention? I can see that they both have SSID pages and that the MAC addresses are different if that helps? They are also set to "Automatic Smart Wireless! Very noobish when it comes to this

    Just to add the phone is connected to the 5ghz wireless on the router and mobile data on the phone is turned off. (edited)
  24. Avatar
    Does your phone auto connect in the supermarkets,restaurants,school or work where you have signed on before.
  25. Avatar
    Author
    BigDom04/01/2022 21:03

    Does your phone auto connect in the supermarkets,restaurants,school or …Does your phone auto connect in the supermarkets,restaurants,school or work where you have signed on before.


    Hi again

    Its still the same on a different wifi connection, I tested it today and the issue still persists? One thing I did also do was this, I turned my router off to see how long it would take for the wireless to toggle of and it took about 16 minutes? I haven't done it again but will at some point today to see if its the same amount of time to go off, not sure if this will help in anyway though but it is interesting the way it took 16mins for its to turn off?

    Thanks again for you help (edited)
  26. Avatar
    You need to move your phone wifi connection from 5ghz (as you previously stated) to 2.4ghz. Some phones have re-connection problems when connection to 5ghz. So you need to connect your phone to the router using 2.4ghz band instead. At the moment I am reluctant to move forward because you're not comfortable with adjusting your settings on the router. I suggest you research about splitting your wifi bands into 2 different SSID names. Look at the manual for your router or go to your providers website(or forum) to find details. Here's a link to a guy with a similar problem. Understanding basic router settings is essential nowadays, I suggest you learn them at your own pace. 16 minutes sounds like a power saving feature on the phone.But not sure. (edited)
  27. Avatar
    Author
    Thanks for all your help BigDom,I followed a simple tutorial on how to change the SSID to separate 2.4 and 5 so now have them both on different passwords and wireless names, I will test in the morning as its far to late now. I will let you know how I get on

    Tyvm again
  28. Avatar
    Author
    BigDom05/01/2022 21:27

    You need to move your phone wifi connection from 5ghz (as you previously …You need to move your phone wifi connection from 5ghz (as you previously stated) to 2.4ghz. Some phones have re-connection problems when connection to 5ghz. So you need to connect your phone to the router using 2.4ghz band instead. At the moment I am reluctant to move forward because you're not comfortable with adjusting your settings on the router. I suggest you research about splitting your wifi bands into 2 different SSID names. Look at the manual for your router or go to your providers website(or forum) to find details. Here's a link to a guy with a similar problem. Understanding basic router settings is essential nowadays, I suggest you learn them at your own pace. 16 minutes sounds like a power saving feature on the phone.But not sure.


    Hi again

    Just to let you know the issue still persists? The phone is connected to the 2.4ghz but the wireless still turns off and needs toggled back on. It does seem to be a power saving issue due to the time taken to toggle off but both power saving features on the phone are turned off? I might just bear with it as its not that big of an issue just more annoying than anything!

    Thanks for all you help
Avatar
Top Merchants