Posted 7th Feb 2023 (Posted 20 h, 47 m ago)
Hi All, so I just installed a new crucial MX500 2T SSD, went into disk management and all was fine with setup and format then rebooted the PC but it wouldn't show a Bois splash screen and just sat there, tried a restart, did the same again, so removed the SSD and the PC booted into windows just fine, tried various sata ports, 2 posts but SSD not detected and another 2 failed posts as before, also tried an external docking station but no sign of life from HDD indicator, Amazon are replacing the SSD, any ideas as to what's gone wrong.

Community Updates
New Comment


sorted by
  1. Avatar
    Could have been faulty and fried itself on the first bit of sustained activity, firmware/controller fault could have caused it to brick itself, could be some physical damage to some flash that causes the controller to lock up when it tries to read from it.

    SSDs have a habit of just dying with absolutely zero warning or symptoms, not as much in the early days but it still happens. Unlike HDDs, there's no clicking, no bad sectors showing in disc scans, no noticeable hard drive thrashing. It just works one minute, is unrecoverably bricked the next.
  2. Avatar
    That happened to me before reformatted the drive and it was working fine again
  3. Avatar
    Had the same problem before. It maybe recoverable according to crucial & might not "fried" but I chose to return it because I couldn't be bothered.

    It does show up somewhere, cannot remember where, maybe diskpart but shows either 0 or 1 mbs storage. (edited)
  4. Avatar
    Thanks for the replies guys, a new replacement arrived today and is working going through the same process, i did note this time the format took seconds unlike the first one which took minutes.
Top Merchants